Markov Random Field Smooths
For data observed over discrete spatial units, a simple Markov random field
smoother is sometimes appropriate. These functions provide such a smoother class for mgcv
.
See details for how to deal with regions with missing data.
## S3 method for class 'mrf.smooth.spec' smooth.construct(object, data, knots) ## S3 method for class 'mrf.smooth' Predict.matrix(object, data)
object |
For the |
data |
a list containing just the data (including any |
knots |
If there are more geographic areas than data were observed for, then this argument is used to provide the labels for all the areas (observed and unobserved). |
A Markov random field smooth over a set of discrete areas is defined using a set of area labels, and a neighbourhood structure for the areas. The covariate of the smooth is the vector of area labels corresponding to each obervation. This covariate should be a factor, or capable of being coerced to a factor.
The neighbourhood structure is supplied in the xt
argument to s
. This must contain at least one of
the elements polys
, nb
or penalty
.
contains the polygons defining the geographic areas.
It is a list with as many elements as there are geographic areas.
names(polys)
must correspond to
the levels of the argument of the smooth, in any order (i.e. it gives the area labels).
polys[[i]]
is a 2 column matrix the rows of which specify the vertices of the polygon(s)
defining the boundary of the ith area. A boundary may be made up of several closed loops: these must
be separated by NA
rows. A polygon within another is treated as a hole. The first polygon in
any polys[[i]]
should not be a hole. An example
of the structure is provided by columb.polys
(which contains an artificial hole
in its second element, for illustration). Any list elements with duplicate names are combined into a
single NA separated matrix.
Plotting of the smooth is not possible without a polys
object.
If polys
is the only element of xt
provided, then the neighbourhood structure is
computed from it automatically. To count as neigbours, polygons must exactly share one of more
vertices.
is a named list defining the neighbourhood structure. names(nb)
must correspond to the
levels of the covariate of the smooth (i.e. the area labels), but can be in any order. nb[[i]]
is a numeric vector indexing the neighbours of the ith area (and should not include i
).
All indices are relative to nb
itself, but can be translated using names(nb)
. See example code.
As an alternative each nb[[i]]
can be an array of the names of the neighbours, but these will be
converted to the arrays of numeric indices internally.
If no penalty
is provided then it is computed automatically from this list. The ith row of
the penalty matrix will be zero everwhere, except in the ith column, which will contain the number
of neighbours of the ith geographic area, and the columns corresponding to those geographic
neighbours, which will each contain -1.
if this is supplied, then it is used as the penalty matrix. It should be positive semi-definite. Its row and column names should correspond to the levels of the covariate.
If no basis dimension is supplied then the constructor produces a full rank MRF, with a coefficient for each geographic area. Otherwise a low rank approximation is obtained based on truncation of the parameterization given in Wood (2017) Section 5.4.2. See Wood (2017, section 5.8.1).
Note that smooths of this class have a built in plot method, and that the utility function in.out
can be useful for working with discrete area data. The plot method has two schemes, scheme==0
is colour,
scheme==1
is grey scale.
The situation in which there are areas with no data requires special handling. You should set drop.unused.levels=FALSE
in
the model fitting function, gam
, bam
or gamm
, having first ensured that any fixed effect
factors do not contain unobserved levels. Also make sure that the basis dimension is set to ensure that the total number of
coefficients is less than the number of observations.
An object of class "mrf.smooth"
or a matrix mapping the coefficients of the MRF smooth
to the predictions for the areas listed in data
.
Simon N. Wood simon.wood@r-project.org and Thomas Kneib (Fabian Scheipl prototyped the low rank MRF idea)
Wood S.N. (2017) Generalized additive models: an introduction with R (2nd edition). CRC.
library(mgcv) ## Load Columbus Ohio crime data (see ?columbus for details and credits) data(columb) ## data frame data(columb.polys) ## district shapes list xt <- list(polys=columb.polys) ## neighbourhood structure info for MRF par(mfrow=c(2,2)) ## First a full rank MRF... b <- gam(crime ~ s(district,bs="mrf",xt=xt),data=columb,method="REML") plot(b,scheme=1) ## Compare to reduced rank version... b <- gam(crime ~ s(district,bs="mrf",k=20,xt=xt),data=columb,method="REML") plot(b,scheme=1) ## An important covariate added... b <- gam(crime ~ s(district,bs="mrf",k=20,xt=xt)+s(income), data=columb,method="REML") plot(b,scheme=c(0,1)) ## plot fitted values by district par(mfrow=c(1,1)) fv <- fitted(b) names(fv) <- as.character(columb$district) polys.plot(columb.polys,fv) ## Examine an example neighbourhood list - this one auto-generated from ## 'polys' above. nb <- b$smooth[[1]]$xt$nb head(nb) names(nb) ## these have to match the factor levels of the smooth ## look at the indices of the neighbours of the first entry, ## named '0'... nb[['0']] ## by name nb[[1]] ## same by index ## ... and get the names of these neighbours from their indices... names(nb)[nb[['0']]] b1 <- gam(crime ~ s(district,bs="mrf",k=20,xt=list(nb=nb))+s(income), data=columb,method="REML") b1 ## fit unchanged plot(b1) ## but now there is no information with which to plot the mrf
Please choose more modern alternatives, such as Google Chrome or Mozilla Firefox.